Программное обеспечение
Строка меню (Menu Bar)
Расположена в верхней части интерфейса программного обеспечения. Строка меню содержит все функции и настройки SLAM GO POST Pro и разделена на следующие категории: Файл (File), Обработка (Solve), Инструменты (Tools), Отображение (Display), Вид (View), Измерения (Measurement), Окно (Window), Справка (Help).
Общая панель инструментов (Common Toolbar)
Расположена в верхней части интерфейса. Общая панель инструментов предоставляет часто используемые функции. Она в основном поддерживает операции, связанные с проектами, обработку данных, базовую навигацию по виду, а также некоторые часто применяемые инструменты.
За исключением инструмента просмотра журналов (LOG), все остальные функции на общей панели инструментов работают так же, как и соответствующие функции в строке меню. Подробную информацию можно найти в соответствующих разделах руководства, посвященных строке меню.
LOG
Используется для просмотра последних файлов журналов активного проекта. Файлы журналов сохраняются в каталоге проекта в папке \log.
Панель быстрого доступа (Quick Access Toolbar)
Панель быстрого доступа расположена по левому и правому краям окна просмотра и включает инструменты для операций, навигации по виду, рендеринга, измерений, обрезающих рамок (клиппинга), панорамных изображений и настройки размера точек. Компоненты можно перемещать, перетаскивая левой кнопкой мыши, а их видимость можно настраивать с помощью правой кнопки мыши.
Окно списка проектов (Project List Window)
Окно списка проектов отображает все открытые в данный момент проекты и показывает каталоги данных, содержащиеся в каждом проекте.
Примечание: Функция пакетной обработки не подчиняется этому ограничению и может обрабатывать все открытые в данный момент проекты.
Окно просмотра (View Window)
Центральная область интерфейса программного обеспечения представляет собой окно просмотра, которое поддерживает однокадровый, двухкадровый и многокадровый режимы отображения. Оно в основном используется для создания новых окон просмотра, окон сечений, панорамных окон и других типов окон.
Журнал обработки и индикатор хода выполнения (Processing Log & Progress Bar)
Журнал обработки (Processing Log) — это окно вывода журнала проекта, в котором отображается статус выполнения задач, а также уведомления об успешном завершении или сбоях.
Индикатор хода выполнения (Progress Bar), расположенный в левом нижнем углу программного обеспечения, в основном показывает текущий ход обработки данных. Он отображает название текущего этапа обработки, общий прогресс и конкретное значение общего прогресса в процентах.
Меню "Файл" (File Menu)
|
Меню "Файл" включает следующие опции:
|
Создание нового проекта (Create New Project)
Создает новый проект для обработки.
Описание функций:
Импорт данных (Data Import) (*): Импорт каталога с необработанными данными для обработки. Обязательный параметр.
Название проекта (Project Name): По умолчанию: SlamProject. Может быть изменено при необходимости.
Время создания (Creation Time): Временная метка создания проекта.
Модель устройства (Device Model): Определяется автоматически на основе файла калибровки устройства в импортированных необработанных данных.
Режим работы (Operation Mode) (*): Режим, используемый при сборе данных, например, ручной (handheld) или ранцевый (backpack).
Система координат (Coordinate System): Эта опция отображается только в том случае, если в импортированных данных присутствуют и действительны данные GNSS. Можно использовать автоматическое распознавание системы координат или нажать значок шестеренки справа для ручного выбора.
Путь проекта (Project Path): Место хранения нового проекта. По умолчанию создается в том же каталоге, что и папка с необработанными данными.
Выбор системы координат (Coordinate System Selection)
Исторические системы координат (Historical Coordinate Systems): Ранее выбранные системы координат. Можно нажать кнопку "Применить" (Apply) для применения выбранной системы координат, а также удалить или изменить системы координат в списке.
Пользовательские системы координат (User-Defined Coordinate Systems): Создайте пользовательскую систему координат, нажав кнопку "Создать" (New).
Создание новой системы координат (Create New Coordinate System): Укажите название новой системы координат, выберите существующий эллипсоид или создайте пользовательский, выберите метод проекции и настройте соответствующие параметры проекции.
Пользовательский эллипсоид (Custom Ellipsoid)
Введите соответствующие параметры эллипсоида для создания пользовательского эллипсоида.
Режим работы (Operation Mode)
Пользовательский режим и настройки эксцентриситета (User-Defined Mode & Eccentricity Settings)
Режим работы – Pack100 + Pano100 Mode & настройки загрузки калибровочного файла
Введите номер устройства Pano100 и нажмите "Загрузить" (Download), чтобы загрузить калибровочный файл.
Открыть проект (Open Project)
Открывает существующий проект.
Недавние проекты (Recently Opened Projects)
В этом разделе перечислены проекты, которые были открыты в программном обеспечении последними. Вы можете дважды щелкнуть по проекту, чтобы открыть его напрямую, нажать кнопку удаления в правом верхнем углу, чтобы удалить выбранный проект из списка, или нажать кнопку "Очистить" (Clear), чтобы удалить все записи о проектах.
Сохранить проект (Save Project)
Сохраняет все открытые в данный момент проекты.
Сохранить проект как (Save Project As)
Сохраняет текущий активный проект под новым именем или в новом местоположении.
Закрыть все проекты (Close All Projects)
Закрывает все открытые в данный момент проекты.
Экспорт данных (Export Data)
Экспортирует данные текущего активного проекта в формате .las. Экспортированные файлы сохраняются в выбранный путь экспорта.
Выход (Exit)
Завершает работу и закрывает программное обеспечение.
Меню "Обработка" (Solve)
Меню "Обработка" (Solve) включает следующие функции:
|
Обработка в один клик (One-Click Solve)
Выполняет однокнопочную обработку текущего активного проекта.
Описание функции – Построение облака точек (Point Cloud Mapping)
Алгоритм построения карты (Mapping Algorithm): Выберите из различных алгоритмов построения карты, разделенных на Алгоритм A и Алгоритм B.
Выбор сцены (Scene Selection): Выберите между "Общая сцена" (General Scene) и "Сцена метро" (Subway Scene). По умолчанию установлено "Общая сцена". Выбор "Сцена метро" переключает на алгоритм построения карты, оптимизированный для условий метро, что повышает качество и точность построения в таких средах.
Расширенные настройки (Advanced Settings): Нажмите кнопку для перехода к расширенным параметрам построения карты, чтобы открыть страницу расширенных настроек. Эта страница включает опции для стабильности сбора данных, заданного времени обработки, а также параметры фильтрации внутреннего и внешнего ограничивающего прямоугольника.
Панорама и окрашивание – Настройки источника изображений (Panorama and Colorization – Image Source Settings)
Источник изображений (Image Source): Определяет источник сшитых изображений для генерации панорамы и окрашивания облака точек. Варианты включают "Встроенная камера" (Built-in Camera) и "Панорамная камера" (Panoramic Camera).
Когда выбран вариант "Панорамная камера", активируется модуль "Параметры панорамной камеры" (Panoramic Camera Parameters):
-
Интерьер/Экстерьер (Indoor/Outdoor): Выберите тип сцены съемки в соответствии с реальными условиями. По умолчанию установлено "Экстерьер" (Outdoor).
-
Режим мобильной замедленной съемки (Mobile Time-Lapse Mode): Если панорамная камера собирала данные в режиме мобильной замедленной съемки, эта опция должна быть отмечена; в противном случае ее выбирать не следует.
-
Путь к данным панорамной камеры (Panoramic Camera Data Path): Укажите путь к папке, содержащей файлы панорамной камеры в формате .insv.
Окрашивание облака точек – Настройки (значок шестеренки справа)
Алгоритм окрашивания (Colorization Algorithm): Выберите между "Стандартное окрашивание" (Standard Colorization) и "Высококачественное окрашивание" (High-Definition Colorization).
Настройки окрашивания (Colorization Settings):
-
Экспорт окрашенного облака точек (Export Colorized Point Cloud): Экспортирует результаты окрашивания облака точек в стандартном формате .las.
-
Выводить неокрашенные точки (Output Non-Colorized Points): Опция для включения точек, которые не были окрашены, в экспортируемые данные.
-
Выводить апсемплированное (увеличенное) облако точек (Output Upsampled Point Cloud): Экспортирует окрашенные результаты в виде апсемплированного облака точек. Результат апсемплинга примерно в 6–10 раз больше исходного, и время обработки соответственно увеличивается.
Пакетная обработка (Batch Processing)
Функция пакетной обработки включает следующие возможности:
1. Список проектов (Project List)
Здесь отображаются другие проекты, которые еще не были добавлены в список обработки, а также вновь созданные проекты.
-
Интегрированное создание нового проекта: Нажмите кнопку "Новый проект" (New Project) внизу, чтобы создать новый проект, что соответствует функции Файл → Новый проект (File → New Project) в строке меню.
-
В левой части списка проектов отображаются все открытые в данный момент проекты и вновь созданные проекты.
-
Нажмите кнопку справа от названия проекта, чтобы просмотреть соответствующую информацию о нем.
-
При щелчке правой кнопкой мыши по проекту в списке доступны опции: "Редактировать проект" (Edit Project), "Сохранить проект как" (Save Project As), "Сохранить проект" (Save Project) или "Открыть папку" (Open Path).
2. Список обработки (Processing List)
-
Выбирайте проекты из списка проектов слева, чтобы добавлять их в список обработки справа по мере необходимости. Даже если в списке обработки уже есть проекты, новые проекты все равно можно добавлять.
-
Используйте четыре кнопки под списком обработки — "Удалить" (Delete), "Очистить" (Clear), "Переместить вверх" (Move Up), "Переместить вниз" (Move Down) — для управления выбранными проектами в списке.
-
Нажмите значок шестеренки рядом с названием проекта в списке обработки, чтобы настроить его параметры обработки. Страница настройки параметров совпадает с функцией Обработка → Однокнопочная обработка (Solve → One-Click Processing) в строке меню.
-
Отображает статус обработки проекта, включая: "Не настроен" (Not Configured), "Не отправлен" (Not Submitted), "Обработка xx%" (Processing xx%), "Завершен" (Completed), "В очереди" (Queue Waiting), "Ошибка обработки" (Processing Failed) и т.д.
3. Отправить (Submit)
Отправляет все неотправленные проекты на обработку.
4. Отмена (Cancel)
Отменяет все задачи обработки.
5. Примечание
Закрытие страницы пакетной обработки не прерывает выполняющиеся пакетные процессы. Вы можете снова открыть эту страницу с помощью кнопки пакетной обработки, чтобы просмотреть текущее состояние пакетной обработки или добавить новые проекты в очередь обработки.
Построение облака точек (Point Cloud Mapping)
Выполняет построение облака точек для текущего активного проекта. Параметры совпадают с настройками построения карты в функции однокнопочной обработки (One-Click Processing).
-
Алгоритм построения карты (Mapping Algorithm): Выберите из различных алгоритмов построения карты, разделенных на Алгоритм A и Алгоритм B.
-
Выбор сцены (Scene Selection): Выберите между "Общая сцена" (General Scene) и "Сцена метро" (Subway Scene). По умолчанию установлено "Общая сцена". Выбор "Сцена метро" переключает на алгоритм построения карты, оптимизированный для условий метро, что повышает качество и точность построения в таких средах.
-
Расширенные настройки (Advanced Settings): Нажмите кнопку для перехода к расширенным параметрам построения карты, чтобы открыть страницу расширенных настроек. Эта страница включает опции для стабильности сбора данных, заданного времени обработки, а также параметры фильтрации внутреннего и внешнего ограничивающего прямоугольника.
Ориентация (Orientation)
Выполняет ориентацию облака точек для выбранного облака точек. Доступны два режима ориентации: Нежесткая (Non-Rigid) и Жесткая (Rigid).
Для нежесткой ориентации не требуется выбирать облако точек; обработка по умолчанию выполняется на основе результатов построения карты.
Оптимизация облака точек (Point Cloud Optimization)
Выполняет оптимизацию выбранного облака точек. Доступны два режима оптимизации: Разреженная оптимизация (Sparse Optimization) и Плотная оптимизация (Dense Optimization).
-
Плотная оптимизация (Dense Optimization): Результат оптимизации сохраняет не менее 90% от исходного размера данных.
-
Разреженная оптимизация (Sparse Optimization): Результат оптимизации сохраняет не менее 30% от исходного размера данных.
Удаление шума (Denoise)
Фильтрует и удаляет изолированные шумовые точки в файле облака точек с использованием статистических алгоритмов.
Устранение искажений (Dedistortion)
Выполняет устранение искажений данных изображения на основе заводских калибровочных параметров для обеспечения точной сшивки панорам и окрашивания облака точек.
Внимание: Для устройств SLAM2000, SLAM200 и SLAM1000 данная функция должна использоваться после этапа окрашивания облака точек.
Окрашивание облака точек (Point Cloud Coloring)
Выполняет наложение текстуры на выбранное облако точек. Параметры совпадают с настройками окрашивания в функции однокнопочной обработки (One-Click Processing).
Источник изображений (Image Source): Определяет источник сшитых изображений для генерации панорамы и окрашивания облака точек. Варианты включают "Встроенная камера" (Built-in Camera) и "Панорамная камера" (Panoramic Camera).
Когда выбран вариант "Панорамная камера", активируется модуль "Данные панорамной камеры" (Panoramic Camera Data):
-
Режим мобильной замедленной съемки (Mobile Time-Lapse Mode): Если панорамная камера собирала данные в режиме мобильной замедленной съемки, эта опция должна быть отмечена; в противном случае ее выбирать не следует.
-
Путь к данным панорамной камеры (Panoramic Camera Data Path): Укажите путь к папке, содержащей файлы панорамной камеры в формате .insv.
Алгоритм окрашивания (Colorization Algorithm) Доступны три алгоритма окрашивания:
Стандартное окрашивание (Standard Colorization): Подходит для большинства типов сцен.
Высококачественное окрашивание (High-Definition Colorization): Обеспечивает заметно более высокую четкость по сравнению со стандартным окрашиванием и подходит для большинства сцен.
Улучшенное высококачественное окрашивание (Enhanced HD High-Definition Colorization): Включает дополнительный этап оптимизации положения (POS), обеспечивая значительно более высокую четкость, чем High-Definition Colorization. Подходит для сценариев, требующих максимальной четкости. Время обработки увеличивается.
Настройки вывода окрашивания (Colorization Output Settings):
-
Экспорт неокрашенных точек (Export Uncolored Points): Опция для экспорта данных облака точек, которые остались неокрашенными.
-
Вывод апсемплированного (увеличенного) облака точек (Export Upsampled Point Cloud): Выводит апсемплированную версию окрашенного облака точек. Результат апсемплинга примерно в 6–10 раз больше, чем без апсемплинга, и соответствующее время обработки также увеличивается.
Генерация панорамы (Panorama Generation)
Выполняет генерацию сшитых панорамных изображений с возможностью выбора источника: встроенная камера (Built-in Camera) или панорамная камера (Panoramic Camera).
Источник изображений (Image Source): Источник изображений для сшивки панорамы и окрашивания. Варианты включают встроенную камеру и внешнюю панорамную камеру.
При выборе панорамной камеры активируется модуль "Данные панорамной камеры" (Panoramic Camera Data):
-
Интерьер/Экстерьер (Indoor/Outdoor): Классифицируйте сценарий сбора данных в соответствии с фактическими условиями. По умолчанию установлено значение "Экстерьер" (Outdoor).
-
Режим движения с задержкой (Motion Delay Mode): Если панорамная камера собирает данные в режиме движения с задержкой, эта опция должна быть отмечена; в противном случае ее нельзя выбрать.
-
Путь к данным панорамной камеры (Panoramic Camera Data Path): Укажите путь к папке, где хранятся файлы панорамной камеры в формате INSV.
Фильтр движущихся объектов (Move Object Filter)
Удаляет динамические объекты из выбранного набора данных с помощью фильтрации.
Предварительное обучение 3DGS (3DGS Pre-Training)
После выбора пути к папке, содержащей файлы панорамной камеры в формате INSV, нажмите "Подтвердить" (Confirm), чтобы начать предварительное обучение 3DGS.
Обучение 3DGS (3DGS Training)
Выполняет дальнейшее обучение на основе результатов предварительного обучения активного проекта. Доступны два режима обучения: Локальное обучение (Local Training) и Облачное обучение (Cloud Training). Подробные инструкции см. в документации: /zh/slam/3dgs/training.
Отмена обработки (Cancel Processing)
Останавливает текущую выполняющуюся задачу обработки.
Меню "Инструменты" (Tools)
|
Меню "Инструменты" включает следующие функции:
|
Преобразование в формат RINEX (RINEX Format Conversion)
Преобразует исходные файлы наблюдений в стандартный формат RINEX, необходимый для постобработки с дифференциальной поправкой.
Обработка PPK (PPK Solution)
Выполняет постобработку кинематических данных (PPK) для эпохальных данных в заданный период, чтобы повысить процент фиксированных решений и достичь более высокой точности позиционирования. Этот метод используется при сканировании зон без сетевого покрытия, где подключение RTK недоступно.
Параметры:
- Данные ровера (Rover Data): Путь к данным наблюдений ровера.
- Данные базовой станции (Base Station Data): Путь к данным наблюдений базовой станции.
- Параметры базовой станции (Base Station Parameters):
- RINEX Header Information: Чтение координат базовой станции из заголовочного файла RINEX.
- Automatic: Автоматическое вычисление координат базовой станции.
- User Defined: Ручной ввод координат базовой станции.
- Longitude: Долгота базовой станции.
- Latitude: Широта базовой станции.
- Height: Высота базовой станции.
- Выбор навигационных данных (Navigation Data Selection):
- Rover: Использовать информацию навигационного файла, записанного в данных ровера.
- Base Station: Использовать информацию навигационного файла, записанного в данных базовой станции.
- Путь вывода (Output Path): Путь для сохранения результатов вычислений.
Отчет о точности (Accuracy Report)
Открывает отчет о точности ориентации текущего активного проекта. Отчет находится в пути проекта в папке \gcp.
Тайлинг (разбивка) облака точек (Point Cloud Framing)
Выполняет разбивку и обрезку выбранного файла облака точек на основе стандартного масштаба карты или фиксированного размера.
Разбивка по масштабу (Frame by Scale): Разделяет облако точек в соответствии со стандартным масштабом карты.
Prefix: Текстовый префикс, добавляемый к выходным файлам разбивки.
Scale: Выбор масштаба карты для разбивки.
Frame Size: Выбор размера каждого фрагмента.
Extension: Расстояние расширения за границы фрагмента.
Starting Point X/Y Coordinates: Координаты X и Y начальной точки разбивки
Фиксированный размер (Fixed Size): Выполняет разбивку на основе фиксированного размера фрагмента.
Prefix: Текстовый префикс, добавляемый к выходным файлам разбивки.
Frame Length: Фиксированная длина каждого фрагмента.
Frame Width: Фиксированная ширина каждого фрагмента.
Frame Size: Выбор размера фрагмента.
Extension: Расстояние расширения за границы фрагмента.
Starting Point X/Y Coordinates: Координаты X и Y начальной точки разбивки.





































